Intermittent problem to load the spreadsheet
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 23:34 PDT
Update
This issue has been fixed, and we are closely monitoring it.
Posted Apr 10, 2024 - 23:30 PDT
Update
We have identified the root cause and deployed the fixes. We are still monitoring the performance to ensure the spreadsheet loads properly.
Posted Apr 10, 2024 - 10:58 PDT
Investigating
Several users unable to load their spreadsheet from the saved filter
Posted Apr 09, 2024 - 22:16 PDT
This incident affected: Spreadsheet View.