Spreadsheet loading issues after forge migration

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 23:32 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2025 - 22:19 PDT

Update

The hotfix has been released and we are monitoring the issues.
Posted Jul 08, 2025 - 22:18 PDT

Identified

We have identified that if a Jira site contains more than 50 projects, the API call used to retrieve all projects enters an infinite loop. We are actively working on a hotfix and will release it shortly.
Posted Jul 08, 2025 - 20:24 PDT

Investigating

Following the recent migration of all Connect modules to Forge modules, some customers have experienced issues loading their spreadsheets. This problem is particularly affecting users with a large number of work items (Jira issues), where performance or loading failures have been reported.
Posted Jul 08, 2025 - 19:16 PDT
This incident affected: Spreadsheet View and Administration.