Unable to open the spreadsheet from the saved filter

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 06:18 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 31, 2025 - 23:08 PDT

Identified

We’ve identified the root cause, the spreadsheet may remain stuck on the loading screen when an edit permission is enabled in the app settings.

Our team has already prepared a fix and is currently running a final round of testing.

As a workaround, you may temporarily remove the edit permission if possible. Otherwise, you can wait for the hotfix to be deployed today.
Posted Jul 31, 2025 - 15:43 PDT

Update

We are still investigating this issue. Rest assured, this issue only affecting a very small number of users under certain conditions.
Posted Jul 31, 2025 - 06:03 PDT

Investigating

We are currently investigating this issue.
Posted Jul 31, 2025 - 01:52 PDT
This incident affected: Spreadsheet View, Spreadsheet Editor, and Spreadsheet Excel-like Features.